Twitter Tools – Plugin update for Valid XHTML

  • Posted February 21, 2011. Last modified February 21, 2011 by

Today I noticed my site was not generating valid XHTML (for the 1.0 Strict Standard). I isolated some of the problems to the “Twitter Tools” plugin for WordPress. The problem is that a couple of parameters are not passed using the correct encoding (The & character is not properly encoded). The changes should be made to the “twitter-tools.php” file. Here is the original source for a couple of the offending lines:

And here it is with the changes made (notice the ‘&’ is replaced with ‘&’):

Hope this helps someone 😛

One comment on “Twitter Tools – Plugin update for Valid XHTML”

Leave a Reply

Your email address will not be published. Required fields are marked *